Common errors made when using SAFIR Problem
Types in GiD
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Introduction

This document explains common and less common errors that are done by users when trying to create
models with the SAFIR Problem Types for GiD.

For each one of the types of errors described, there’s an indication of the Problem Types to which that
error is related to. The list of Problem Types are:

- Safir_Thermal_2D
- Safir_Thermal_3D
- Safir_Thermal_tsh
- Safir_Structural_2D
- Safir_Structural_3D
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Common errors

Forget to transform a pre-existing model when an update of the Problem Types is done
Problem Types: All Problem Types

Whenever an update of the Problem Types is done (i.e. a new version of the Problem Types is
downloaded and added to the folder “problemtypes” in GiD), and you plan to do modifications to a
model created with a previous version of the Problem Types, a transformation of the model should be
done.

To do this, open the file with the model in GiD and go to Data > Problem Type > SAFIR2016 >
CurrentProblemType:
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Then, select the option Transform to new problemtype and click on Ok:
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GiD x64 Project: IPE220 (SAFIR2016\Safir_Thermal_2d) - O X
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An information window will tell you if everything went ok in the transformation.
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Have linear elements meshed in thermal analysis
Problem Types: Safir_Thermal_2D, Safir_Thermal_3D, Safir_Thermal_tsh

When meshing a thermal model, you should make sure that only the surfaces in Safir_Thermal_2D and
Safir_Thermal_tsh models, or the volumes in Safir_Thermal_3D models, are meshed.
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To achieve this:

- All the fields in mesh always by default in the Preferences Window (access it by going to
Utilities > Preferences) should be unticked:
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Files View Geometry Utilities Data Mesh Calculate Cross-Section About Problem Type Help
P
0 @ 9 | @ab@:@%"}’ ‘ é = Preferences Window - @ ?
o e B General Others Generate
‘ Interface Smoothing:[Normal
= MeshView
“‘5_)‘ @ . Oﬁ?er [ Mesh until end )
J= @ B} Gra:hlca\ [ No mesh frozen layers Boundaries
= earance . -
{5 ______ Cz::urs [] Avoid elements with all its nodes in boundary AssignSizes
0 | - System [[] Allow quadrilateral dominant meshes Structured
f H= [} Meshing Mesh always by default StructConcentr
< 3 - Main [J o Points ElemType
1" Lines L
\ & Boundary layer 0 - ctaces MeshCriteria
]
"\ = Cartesian mesher L Quadratic
e i L. Sphere mesher Chordal error:[] )
£j£ e ] * Import and Export Minimum element size: 0
R ﬂ - Fonts Maximum chordal error in model CancelMesh
i - Grid Relative(%): 0 EditMesh
"-Cl’ 1 * Postprocess Absolute: 0 CreateBoundary
:H ’ DrawSizes
= = | gy ¥y
- MeshFromBounc
‘ [ i 3 Default values
- | Q‘ DrawRjumpSkip
x .
2 Arg Close ConnectPoints
212,
ﬁ SK. SemiStructured
®4
Meshing. Wait, please... [a)
Size changed automatically to some entities
v
Command: | ‘ ﬁ. -+
Zoom: 0.998x Nodes: 110, Elements: 120 Render: Normal Layers: 1 (-0.1177, 0.1283, 0) Pre
- And/or the mesh criteria should be overridden in Mesh > Mesh criteria > No mesh > lines:
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You can check that a correct meshing of the elements has been done after GiD generates the mesh, by
looking at the type of the elements meshed in the information box:
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Not correctly applying two materials of the same type in a thermal analysis
Problem Types: Safir_Thermal_2D, Safir_Thermal_3D, Safir_Thermal_tsh

If you wish to have more than 1 instance of a type of material (e.g. two Steel materials STEELEC2EN
and STEELEC3EN, or two STEELEC2EN with different properties) in a thermal model, you should create
a new material. Go to Data > Materials:

Materials \ Materi
— n — Mew Material n—
‘STEEL V‘ @ m A E2 w2 | &) |STEELE my K2 | &
N !

Thermal | Mechanical . Thermal | e Enter hew Matertial name
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|
Convection Coeff cold|4 i Convecti Ok Cancel
Relative Emission|0.7 Relatve ermission|u. r
Assign Draw Unassign Exchange Assign Draw Unassign Exchange
Close Close

You can check a correct application of the materials by going to Draw > All Materials:
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Forget to define the torsion constraint for torsional analysis
Problem Types: Safir_Thermal_2D

If you're creating cross-sections with the Safir_Thermal_2D Problem Type to use later in a Structural
3D analysis, you’ll have to apply a torsional constraint at one point located in one of the axes of

symmetry of the section.

To do this, go to Data > Conditions:
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Choose the condition Torsion Constraint and apply it to one node in one of the axes of symmetry:
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Afterwards, you can do Draw > Colors to see if the condition has been correctly applied:
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GiD x64 Project: UNNAMED (SAFIR2016\Safir_Thermal_2d) - O X
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Have geometrical entities overlapped
Problem Types: Safir_Structural_2D, Safir_Structural_3D

Sometimes, due to an incorrect input of the points, lines, surfaces or volumes, there may be an overlap
of some of these entities that will lead to errors later when trying to run the model in SAFIR. Use the
command Collapse to solve this problem.

Go to Geometry > Edit > Collapse and choose either one of the type of entities available or Model, if
you wish to collapse all of them:

Safir_Structural _3D x64 Project: slab (SAFIR2016\Safir_Structural_3d) — O X
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Sometimes the error in the model may not be related to overlapped lines. In that case, you can do
Utilities > Repair Model to ask GiD to repair some information about the entities in the model:

Safir_Structural_3D x64 Project: slab (SAFIR2016\Safir_Structural_3d) - [m] X
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Use quadratic type of finite elements instead of normal type
Problem Types: All Problem Types

SAFIR uses first degree Finite Elements (elements that have two points of calculation of the differential
equations and hence have linear solutions). This means that the option Mesh > Quadric type > Normal
should be always selected, otherwise an error will occur:

Safir_Structural_3D x64 Project: slab (SAFIR2016\Safir_Structural_3d) - O X
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Forget to match the NBEAM and NSHELL fields to the number of .tem files and .tsh files
Problem Types: Safir_Structural_2D, Safir_Structural_3D

The number of different cross-section files used for both BEAM and SHELL elements should be specified
in the window containing the general information about the model.

For instance, in the model in the figure below there are 5 types of cross-sections:
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This number has to be written in the field NGEOBEAM in the Window General, which is reached by
going to Data > Problem Data:
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Mesh 3D Finite Elements that are not Hexahedrals
Problem Types: Safir_Thermal_3D, Safir_Structural_3D

Currently, SAFIR only has Hexahedral elements implemented as SOLID elements and therefore, in the
Safir_Thermal_3D and Safir_Structural_3D Problem Types, you should make sure the mesh in volumes
is created using this type of elements:
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Define file names in structural analysis with more then allowed number of characters
Problem Types: Safir_Structural_2D, Safir_Structural_3D

The total length of a .tem file name used in a structural analysis has to be 29 or less than 29 characters
long, and the name of a function file has to be less or equal to 10 characters long.

This is something not related to GiD directly, but that needs to be noticed by user.

Less common errors

Section not created near the origin of the axes
Problem Types: Safir_Thermal_2D

The origin of the axes (i.e. the point of coordinates 0,0) in a cross-section model is the point where, by
default, will pass the line of a BEAM element that uses that cross-section in a structural model.

Ideally, the cross-section should be created around its centre of gravity. If you later wish to set some
eccentricity for the cross-section in the structural model, you can change the coordinates of the
NODELINE command in the .tem file for that cross-section. Below is the visualization in Diamond of a
cross-section where the origin of the system of coordinates is at the centre of gravity.
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¥ IPE220.XML - O X
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Even if you don’t plan to use the cross-section in a structural analysis, the coordinates should be in the
surroundings of the origin of the axes, as not doing so may cause problems later in the analysis with
SAFIR or in the visualization of results with DIAMOND (i.e., for instance, don’t model a section that is
built around the coordinates x = 1000m and y = 1000m).

Have a void between two surfaces that are not connected
Problem Types: Safir_Thermal_2D

The Problem Types for SAFIR don't allow the creation of a void that is defined by two faces that are
not connected, like the case presented below (image taken from DIAMOND):
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However, you can create the section with GID by defining two different voids, as shown in the image below,
and do a small set of changes in order to make it work:
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i

After the creation of the model start the calculation in GID. The calculation will not run successfully in
GID, but the .in file inside the GID folder will be created.

You can then modify the .in file in order to have the void properly defined, by taking the following
actions:

1) Change the NVOID from 2 to 1
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2) Change FRTIERVOID number to allow for the total number of surfaces present in the void

2) Make the two voids in the .in file just one, by deleting the lines that are defining the end of the
1st void and the beginning of the 2nd void:

END_VOID
VOID
You can repeat this process for the n number of voids similar to this that you have on your model.

Give bad orientation to the normals for SOLID and SHELL elements
Problem Types: Safir_Thermal_2D, Safir_Thermal_tsh, Safir_Structural_3D

The normals in GiD define the orientation of the geometry entities and of the mesh entities. This has
an impact on how the nodes are organized in the different elements that compose the mesh.

a) For SOLID elements in Safir_Thermal_2D and Safir_Thermal_tsh, SAFIR requires the definition of the
nodes in a counter clock-wise fashion, and hence the normals of the surfaces in GiD need to have the
same orientation as the global Z axis of the model. You can check the normals by doing View > Normals
> Surfaces > Normal:
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By rotating the camera you’ll see the orientation of the normals on the surfaces:
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You can use the command Utilities > Swap Normals > Surfaces > Select to swap the direction of the
normals in case some of them are not correctly oriented:
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Pick LEFTMOUSE to rotate (ESC to quit). A
Pick LEFTMOUSE to rotate (ESC to quit).
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b) For SHELLs, the model will run no matter the way the normals are oriented in the surface entities,
but these will define the orientation of the local z axis in the SHELL elements.

You can access the menu Normals > Surfaces > Colored to more easily compare the orientation of the
different shells in the model:
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The previous model has different orientations for the surfaces, and hence the resulting SAFIR model

will have different orientation of the local axes (image below taken from Diamond).
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