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Example for GID-SAFIR 2D and 3DThermal 

Analysis 
 
 

Exercise n°11 – Cofraplus 60 
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A.  Create .TSH Cofraplus 60 section 
 
In this example we are going to design a slab with Cofraplus 60 with concrete C 

30/37 of 62mm high and smooth mesh with a diameter equal to 6 mm 150/150 

localized 31 mm from the top of the slab for a slab total thickness of 120 mm. 

 

If we refer to the EN 1994-1-2 §D.1: 

 

 

 

 

 

 

 

 

 

For thermal analysis, the effective thickness of a composite slab heff is given by the 

formula: 
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For a Cofraplus 60: 

l1 = 101 mm; l2 = 62 mm; l3= 106 mm; h1 = 62 mm and h2 = 58 mm (d = 120 mm) 

We obtain heff = 84.8 mm  

Now we are going to create a .TSH section with a shell thickness of 0.0848 mm of 

concrete  

1. Create a project in 2D for TSH Thermal Analysis 

 

From the pull down menu select: 

 Data->Problem type->SAFIR2011->Safir_Thermal_TSH  

 

To save the project select (or use icons on the left): 

 Files->Save         or        or [Ctrl + s] 

 

 If Caps lock is active on your keyboard, shortcut don’t work 
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Enter a file name, eg.: Cofra60 

GiD creates a directory with the name Cofra60 

GiD creates a number of system files in this directory. 

When you start the SAFIR calculation the Safir . IN, .OUT and .TEM files will be 

created in this directory.  

2. Create the geometry in the xy-plane 

 
GiD will open automatically a new window. 

Fill as below: 

 

  

Click on Apply 

 

 It is very important to center all the element 

In order to center correctly this shell element, we have to move it on the y direction: 

Press [Ctrl + v] and fill as below: 
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3. Assign a temperature curve 

 

From the pull down menu select: 

 Data->Conditions 

 

Select: 

On the first pull down list: Frontier constraints 
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On the Temperature curve pull down list FISO 

Click on the Assign button and assign it to the lower line as shown below 

 

 

Press [Esc] or click on Finish to confirm 

Select DRAW->Colors in the Conditions dialog box to display the frontier constraints 

Press [Esc] or click on Finish to leave this view mode  
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On the Temperature curve pull down list F20 

Click on the Assign button and assign it the upper line as shown below 
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4. Assign Material 

 

From the pull down menu select: 

 Data->Materials 

Select CONCRETE from the dialog box pull down list 

 

Then select: 

SILICONC EN as Material Type 

A specific mass of 2400 

A moisture content of 46 

A Convection Coeff hot of 25 

A Convection Coeff cold of 4 

A Relative Emission of 0.7 

A Parameter of thermal conductivity of 0.5 

Click on Assign-> Surfaces and assign it to the surface 

Press [Esc] or Finish to confirm 
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Select DRAW->all materials in the Material dialog box to display Materials 

Press [Esc] or Finish to leave 
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5. Meshes 

 

To create meshes select from the pull down menu: 

 Mesh->Generate mesh     or use [Ctrl + g] 
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6. Assign General Data 

 

From the pull down menu select: 

 Data->Problem Data 

 

 

 

 

In the Problem Data dialog mask enter: 

TIMESTEP, UPTIME, TIMEPRINT as needed 

Click on the Accept data button 

 

 When you click with the right button on one of the variables, GiD will display an 

online help message. The variables are also described in more detail in the SAFIR 

reference manual.  
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Click on the Rebar-Layer tab and fill as shown below: 

 

 

 

 Rebars is is the number of rebar layers in the section type 

 MATERIAL is the local number of this layer, in this case it is equal to 2. You will 

have to define the rebar material type for the mechanical calculation.  

 SECTION is the cross sectional area of rebar1 in this layer in [m
2
/m]. In this 

case it represent a 150x150 gird with a rebar diameter of 6 mm: 

 

 

 

 

 LEVEL is the position of this layer in y axe  with respect to the thickness (GiD-

Safir always create new TSH section centered in Y) 

 Angle is the angle in degrees between the local axis x and the layer or rebars 

 

mmeSection /65.188
150.0

4/006.0 2
2

−=∗= π



GiD-Safir                 Tutorial - 12/2011 

 

 13 

7. Start the calculation 

 
From the pull down menu select: 

 

 Calculate->Calculate window 

 

Click the Start button 

 

 

GiD creates a .IN file in the project directory and starts the calculation. 

In the output window you can see the calculation progress from SAFIR and the GiD 

interface program which generates GiD postprocessor files from the .OUT file. 

 

 If SAFIR found some errors in the .IN file you will see the error message in this 

window.  
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B. Create .TEM sections 
 
The objective is now to create all .TEM files: one IPE300 cold section, one IPE300 hot 

section and one IPE400 cold section. All those sections have to be realizing as 

explained in exercise 3 with a slab 120 mm wide. 

 

1. Create a project in 2D for Thermal Analysis 

 

From the pull down menu select: 

 Data->Problem type->SAFIR2011->Safir_Thermal_2d  

 

To save the project select (or use icons on the left): 

 Files->Save         or        or [Ctrl + s] 

 

 If Caps lock is active on your keyboard, shortcut don’t work 

Enter a file name, eg.: IPE300_H 

GiD creates a directory with the name IPE300_H.gid 

GiD creates a number of system files in this directory. 

When you start the SAFIR calculation the Safir . IN, .OUT and .TEM files will be 

created in this directory. 
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2. Create the geometry in the xy-plane 

 

From the pull down menu select: 

 Cross-Section->I-Profile 

 

 

 

Select IPE as type, IPE 300 as Profile, tick exact shape, put 500 mm as slab width and 

a slab height of 120 mm 

Click on Apply 

 

 GiD-Safir will create an IPE300 profile. The center of this profile will be 

automatically centered on the 0,0 point of the xy-plan 
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3. Assign a temperature curve 

 
From the pull down menu select: 

 Data->Conditions 

 

Select: 

 

The  button 

On the first pull down list: Frontier constraints 

On the Temperature curve pull down list FISO 

 

 

Click on the Assign button and assign it to profile and slab lines as shown below: 
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Press [Esc] or click on Finish to confirm 

 

Select DRAW->Colors in the Conditions dialog box to display the frontier constraints 

Press [Esc] or click on Finish to leave this view mode 

 

Then select F20 as temperature curve 

 

 

 

And assign it to the upper line of the slab, as shown previously 
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4. Assign Material 

 

From the pull down menu select: 

 Data->Materials 

Select STEEL from the dialog box pull down list 

Then select fill as shown below: 

 

 

 

As notified in the Eurocode 1993-1-2, formula (4.26a), for I-sections under nominal 

fire actions, the correction factor for the shadow effect may be determined from:  

 

 

 

 

[Am/V]b is the box value of the section factor [1/m] 

Am/V  is the section factor for unprotected steel members [1/m] 

For an IPE300: 
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As explained in Eurocode 1993-1-2, formula (4.25), you can apply this coefficient to 

the GiD-Safir convection coefficient hot and relative emission  

 

 

 

 

 

 

395.1725*69583.0 =
487.07.0*69583.0 =



GiD-Safir                 Tutorial - 12/2011 

 

 20 

 

Click on Assign-> Surfaces and assign it to the IPE300 surface 

Press [Esc] or Finish to confirm 

Select DRAW->all materials in the Material dialog box to display Materials 

Press [Esc] or Finish to leave 

 

Select CONCRETE from the dialog box pull down list 

Then fill as below: 

 

Click on Assign-> Surfaces and assign it to the slab surface 

Press [Esc] or Finish to confirm 
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5. Create the mesh 

 

Select the slab surface and press [Esc] to confirm 

 Mesh->Generate mesh     or use [Ctrl + g] 

 

Enter 0.04 as size of elements to be generated 

 

 A message with the number of nodes and the number of elements will appear. If 

you are using an evaluation version of GiD, the maximum allowed is 1010 nodes 
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6. Assign General Data 

From the pull down menu select: 

 Data->Problem Data 

Fill as shown below: 

 

The global center is automatically centered in the center of the IPE profile. In order 

to position it correctly in comparison to the shell element already designed the 

global center (Yo) have to be shift: 

ipe300 height/2 + (slab thickness – 0.31) = 0.3/2 + 0.89 = 0.239 m   

 

In the Problem Data dialog mask enter: 

TIMESTEP, UPTIME, TIMEPRINT as needed 

Click on the Accept data button 

 

 When you click with the right button on one of the variables, GiD will display an 

online help message. The variables are also described in more detail in the SAFIR 

reference manual.  
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7. Start the calculation 

From the pull down menu select: 

 Calculate->Calculate window 

Click the Start button 

 

Click the Output View button 

 

GiD creates a .IN file in the project directory and starts the calculation. 

In the output window you can see the calculation progress from SAFIR and the GiD 

interface program which generates GiD postprocessor files from the .OUT file. 
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 If SAFIR found some errors in the .IN file you will see the error message in this 

window. Don’t forget to put the temperature curve fill into the GiD-Safir file. 

 

Then create an IPE300_C.tem file (the same file without frontiers constraints 

conditions). To create it, open the IPE300_H file, search the word “HOT” and replace 

it by “COLD” and delete all the following text. 

 

 

 

Save this new file IPE300_C.tem 

As for IPE300_H.gid file, create an IPE400_H and IPE400_C.gid file  
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C. Create the 3D structure 
 
 

 
 

1. Create a new project of type Safir_Structural_3d 

 

From the pull down menu select: 

 Data->Problem type->SAFIR20011->Safir_Structura_3d 
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To save the project select (or use icon on the left): 

 Files->Save        or or [Ctrl + s] 

 

 If Caps lock is active on your keyboard, shortcut don’t work 

 

Enter a file name, eg.: Fracof 

GiD creates a directory with the name Fracof.gid 

GiD creates a number of system files in this directory. 

When you start the SAFIR calculation the SAFIR .IN and .OUT file will be placed in this 

directory.  

2. Create the system geometry 

 

To change to the 3d isometric view select from the pull down menu: 

 View->Rotate->isometric        

Or if you want to define a point of view by your own use:  

 View->Rotate->Trackball             or [F7] or 

Create the system lines: 

 Geometry->Create->Straight Line      or  

Enter in the command line (at the bottom of the widows): 

0,0,0 0,8,0 and press [Enter] 
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To create the 2 other lines:  

 

 Utilities->Copy         or [Ctrl + c] 

And fill as shown below: 

 

 

Then click on select and select the line and press [Esc] 
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To see nodes and beams numbers select: 

 View->Label->All in-> Nodes 

 

3. Define constraints for the supports: 

 

From the pull down menu select 

 

 Data->Constraints 

 

Select x,y and z constraints and assign them to POINT 1, 2, 7 and 8 and press [Esc]. 

In the dial box, with Draw->Colors you can display the constraints. 
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Press Finish or [Esc] to leave this view mode 
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4. Define loads 

 

From the pull down menu select: 

 

 Data->Loads 

 

 

In the dial box select Global Shell-Load    and enter a Z-Pressure of –6 870 N/m2 and 

Assign it to all surfaces. 

 

To display the loads select Draw->Colors in the dial box 

Press Finish or [Esc] to leave this view mode 
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5. Create Local axes 

 

Local Axes: The orientation of the cross-section is controlled by defining a local axes 

X’Y’Z’ –system.  

 

 Unlike SAFIR which needs a 4th node to describe the orientation of a cross section on a 

beam, the GiD-SAFIR interface uses a local X’Y’Z’ axes system. 

When you start the SAFIR calculation the GiD-SAFIR Interface creates the 4th node in the 

X’Y’ plane. If the center of the local axes is not located on the system line of the beam, the 

direction vector of the Y’-axis is used together with the starting point of the beam to 

define the 4th node. However the GiD-SAFIR interface will issue a warning message in the 

View-output window of the calculation run  

 

The objective is to create 3 named local axes (LAX, LAY, LAZ) with a X’ direction and an 

angle as shown in the figure below. 
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From the pull down menu select: 

 Data->Local Axes->Define 

Enter the name of the new local axe LAY 

Select XandAngle 

 

Press [Ctrl+a] to select the local axe center. Do the same operation to select a point in 

the positive x’ axe of your local axe (in this case you have to select a point in Y direction). 

Set an angle in order to get your y’ direction (4th node) 
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Do the same operations in order to create local axes LAX  

To draw local axes select: 

 Data->Local Axes->Draw all 

 



GiD-Safir                 Tutorial - 12/2011 

 

 35 

6. Assign temperature files (.TEM  and .TSH files) 

 

The objective is to assign the .tem file named (IPE300_C; IPE400_C and IPE300_H) to the 

system lines 

 

 

 

From the pull down menu select: 

 Data->Properties 

In the dial box change the File-Name: safir.tem to the temperature file (.TEM file) of the 

cross-section, in this case IPE300_C.tem. 

Change Local-Axes from -Automatic- to LAY 

In this case all cross-sections have two materials (Steel and concrete as defined during the 

.TEM creation) 
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Assign the IPE300_C.tem section to beams (in this case beams 1-2 and 7-8). 

Do the same operation in order to assign a .tem file to all systems lines 

 

 Don’t forget to change the local axe and materials numbers 

 

To display Property select in the dialog box: 

Draw->Colors 

Press Finish or [Esc] to leave this view mode 
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To display local axes select in the property dialog box: 

 

 Draw->All conditions->Only local axes 

Press Finish or [Esc] to leave this view mode 

 

From the pull down menu select: 

 Data->Properties 

Open the SHELL Section property tab and change the File-Name: test.tsh to the temperature 

file (.TSH file) of the slab section, in this case cofra60.tsh. 

In this case the slab has two materials (Mat 1 = concrete and Mat 2 = Steel S500) 
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Then assign this .TSH to the entire slab 

 

 

 

To display Property select in the dialog box: 

Draw->Colors 

Press Finish or [Esc] to leave this view mode 
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7. Define global materials: 

 

I this case we are using 4 different materials: one steel for rebars, one steel for beams, 

insulation for .TEM slab and concrete for .TSH slab. 

  

To define materials select from the pull down menu: 

 Data->Material 

In the general tab, put 4 materials. 

 

 

As defined in the property part, steel S355 is material 1, insulation is material 2, concrete is 

material 3 and steel S500 is material 4:¨ 
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Click on Accept 
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8. Define the Mass 

 

To define the mass for dynamic calculation, select from the pull down menu: 

 

 Data-> Mass 

Select the  tab, put 100 kg/m as Distributed-Beam-Mass and 2 as Rotational-Inertia 

 

 

 

Assign the mass to all the beam elements 

 

To display Property select in the dialog box: 
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Draw->Colors 

Press Finish or [Esc] to leave this view mode 

 

 

Select the shell tab, put 300 kg/m2 as Distributed-Shell-Mass 

 

Assign the mass to all the shell elements 

 

To display Property select in the dialog box: 

Draw->Colors 

Press Finish or [Esc] to leave this view mode 
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9. Define general data 

 

Select from the pull down menu: 

 

 Data->Problem Data 

 

And fill as shown below 

 

Enter the following  

NGEOBEAM = 6 (the number of .tem files) 

NFIBERBEAM = 300 (max. number of fibers) 

TIMSTEP, UPTIME, TIMEPRINT as needed  

In the Output optional results tab, you can change what GiD-Safir will print during the 

calculation 

 

 Ngeobeam is the number of .TEM files (6 in this case) 

Nfiberbeam is equal to 300 in this case, the only way to find this number is to open .TEM files 

you are using with a text editor and read the number of fiber beam on each of them (on the 
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first line). Keep the largest fiber beam number you found out and use it as your Nfiberbeam in 

your problem data. 

 

 The Postprocessor Diamond can’t open a file bigger than 1.1 Go. It’s important to choose 

your Timeprint  and other Output optional results carefully 

 

 You can change TimestepMin, Precision, Timestep, Ttimestepmax and Timeprint as 

needed but you have to be careful that your UPTIME is less or equal to the UPTIME used 

for thermal 2D calculation 

 

Click on Accept to save your modification 
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10. Generate the mesh: 

 

Select from the pull down menu: 

Preferences: 

 

 

Then select the Meshing tab: 
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And select beam as “mesh always by default” 

Click on Accept 

Then select: 

 Mesh->Element type->Quadrilateral 

Select all the structure 

Then select 

 Mesh->Generate       or [Ctrl + g] 

 

Enter the element size of 0.50 m 
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To display elements and nodes numbers select from the pull down menu: 

 View->Label->Al 

If you want to zoom in use select:  

 

 View->Zoom->In            or  

And zoom on the area you want to check  

To quit the label mode use 

 View-> Lapel-> Off  
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11. Start the calculation: 

 

Select from the pull down menu: 

 

 Calculate->Calculate window 

 

 

 

Click on the Start button then on the Output view button 

 

If you are not satisfied with the mesh repeat meshing and change the element size. 
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Select from the pull down menu: 

 Calculate->Calculate window 

 

Click the Start button and then the Output view button GiD creates a .IN file in the 

project directory and starts the calculation. In the output window you can watch the 

calculation progress from SAFIR and the GiD interface program which generates GiD 

postprocessor files from the .OUT file. 

 

 If SAFIR found some errors in the .IN file you will also see the error message in this 

window. It happens when you forgot to copy all .TEM files into  the project directory, or if 

you entered a wrong number for NGEOBEM or NFIBERBEAM. 

 

 Post processing can be done with Diamond2011. The .OUT file is located in the project-

name.gid directory . The file name is project-name.out  

For post processing with GiD select from the pull down menu:  

Files->Postprocess or click the Postprocessor Icon in the tool box.  

 

 
 


