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GiD – SAFIR 3D-Structural Analysis User Interface 
 

1. Create a GiD project of type Safir_Structural_3d 

From the pull down menus select: 

Data->Problem type->SAFIR2007-> Safir_Structural_3d 

Save the project by selecting from the pull down menu: 

File->Save as… 

GiD creates a directory with the entered project-name expanded by .gid  and places a 
number of help-files in this directory. 

2. Create the system geometry  

Units must be meters.  

Construct the system geometry in 3D using GiD geometry commands . To change the 

view to Isometric select from the pull down menu: 

View->Rotate->Isometric 

For beam and truss elements geometry is in most cases built by line entities. 

Geometry->Create->Line 

For shell elements GiD geometry must be built using NURBS surfaces. 

Geometry->Create->NURBS surface 

The complete set of geometry commands you will find under: 

Geometry->Create 

Geometry->Edit 

Geometry->Delete 

See also the menus: 

Utilities->Copy and Utilities-Move 
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The GiD Window 

 

For details on how to create and manipulate geometry, look to the GiD reference 

manual or online Help. 

3. Define constraints for supports 

From the pull down menu select: Data->Conditions->Constraints 

The following dialog box is displayed: 
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Select the appropriate constraints you need for a support, click the button Assign to 

assign the constraints to a point (or node if you are in the mesh-view) of the structure. 

To assign constraints to a line, click to the line icon on the constraints dialog box. 

  

Note: The GiD-SAFIR interface allows only constraints in the GLOBAL coordinate 

system. 
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4. Define Connections 

To disconnect certain degrees of freedom on the end-node of beams or shells select 

form the pull down menu select: Data-> Connections 

 
 

To disconnect some degrees in one point, mark the degrees to disconnect in the dialog 

box and give an Identifier. Assign this Identifier to a point (Node). 

Note: The GiD-SAFIR interface will create for this point a SAME-point. 

 

 Then, assign the same identifier using condition Disconnect_Id to all the beam 

elements that must form a rigid group disconnected from this node. 
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Alternately you can assign this Identifier to a surface. 

 
 

 

5. Define Loads 

From the pull down menu select: 

Data ->Loads 

The following dialog box is displayed: 

 

Enter Forces in Newton (N), Moments in Nm and assign it to points (nodes) of the 

system geometry. 

To assign distributed loads to system lines click to the line-icon of the dialog box: 
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Enter values in N/m to assign distributed loads to a system line. After meshing this 

load is automatically transferred to all beam-elements of this system line. 

To assign distributed loads to surfaces click to the surface-icon of the dialog box: 

 

To view assigned loads click to the button Draw and select Colors. 

6. Assign the temperature files to beam and truss elements 

Form the pull down menu select: 

Data ->Properties 
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Enter in the field File-Name the name of the Temperature file (.TEM file ) for a cross-

section of beam. 

Note: Unlike SAFIR which needs a 4th node to describe the orientation of a cross 

section on a beam, the GiD-SAFIR interface uses a local X’Y’Z’ axes system.  

 

When you start the SAFIR calculation the GiD-SAFIR Interface creates the 4th node in 

the X’Y’ plane.  

Local-Axes: With this option you define the orientation of the cross section on a 3D-

Line. From the pull down list select Automatic, Automatic alt or Define. 

Automatic: the local axis system is assigned automatically to the beam by GiD. The 

final orientation can be checked with the Draw Local Axes option in the GiD 

Properties window. 

Note: The intuitive idea is that vertical beams have the Y' axe in the direction of 

global X. All the other beams have the Y' axe horizontal and with the Z' axe pointing 

up. 
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Automatic alt: Similar to the previous one but an alternative proposal of local axes is 

given. Typically, User should assign Automatic local axes and check them, after 

assigning, with the Draw local axes option. If a different local axes system is desired, 

normally rotated 90 degrees from the first one, then it is only necessary to assign again 

the same condition to the entities with the Automatic alt option selected. 

 Define. You can create a different named local axes systems either with 3 points or the 

X’ direction and an angle. 

 To display the local axes select: 

 Draw->All conditions->Only local axes 

Enter the number of materials used in this cross-section. For each local material 

number ( this is the material number in the .TEM file ) of this section enter the global 

material number in the structure (this is the material number in the Problem data -> 

General ->Material ). 

Assign the data to a system-line (or to linear elements, if you are in the mesh-display) 

To display assigned properties click the Draw button and select Color. 

To assign Properties to TRUSS elements click to the arrow-icon and select TRUSS 

Cross Section: 

 

Enter the Temperature File-Name of the temperature curve. 
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Enter the Area of the cross section in square meters. 

Enter the Global material number. 

Assign the properties to a system line (or to linear elements in the mesh). 

7. Assign temperature files to shell elements 

Form the pull down menu select: 

Data-> Properties 

and click to the surface-icon on the Property dialog box: 

 

 

Enter the name of the temperature file ( .TSH file ) and the number of materials used 

in the shell-section. 

Assign to each local material in the shell section the global material number of the 

material defined in the Problem ->Material. 

Assign the property to a surface. 

8. Assign mass to nodes, beams and shells 

In the case of DYNAMIC calculation assign masses to nodes, beams and shells. 



GiD – SAFIR2007 3D Structural Analysis 

D.I. Herwig Schönberger / 14.06.2007 

10

Select from the pull down menu: 

Data ->Mass  

 

Mass 1 is the mass [kg] linked to degree of freedom 1 of the node. 

Mass 2 is the mass [kg] linked to degree of freedom 2 of the node. 

Mass 3 is the mass [kg] linked to degree of freedom 3 of the node. 

To assign self-weight mass to beam elements click to the line icon . 

 

Distributed-Beam-Mass is the self-weight in kg/m of the beam. 

Rotational-Inertia:  (See §3.2 Series 23 SAFIR Ref.Manual) 

Use Assign to assign this property to a system line. 

To assign self-weight mass to shell elements click to the surface icon . 
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Assign the Distributes-Shell-Mass in kg/m2 to as surface. 

9. Assign general problem data 

Form the pull down menu select: 

Data->Problem Data 
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This Dialog Box provides 2 tabs:  

• Calculation Parameters 

• Output optional results 

Parameters you can set here are described in more detail in the SAFIR Ref. Manual. 

Title: Allows to enter 2 text lines, which are used as title in SAFIR 

If one of the entered values is too small, SAFIR stops the calculation and writes the 

values needed in the .OUT-file, respectively to the GiD Output window. Change the 

values and restart the calculation. 

Renumber:  select RENUMGEO from the check box to reduce the bandwidth of the 

stiffness matrix. 
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Loads: Allows selecting the type of calculation. You can select from the pull down list 

• STATIC PURE_NR 

• STATIC APPR_NR 

• DYNAMIC PURE_NR 

• DYNAMIC APPR_NR 

• STATICCOLD PURE_NR 

• STATICCOLD APPR_NR 

Convergence:  You can select COMEBACK and NOCOMEBACK 

TimestepMin:  Is the minimum time step in case of COMEBACK 

Precision: Is the small value, which must be reached for convergence. 

NGEOBEAM:  Enter the number of different beam cross sections having the same 

geometry, materials and temperature history. (  or in other words, this is the number of 

.TEM  files ) 

 

NG: Number of integration points for beam elements in longitudinal direction ( can be 

2 or 3, for HASEMI calculation NG must be 2 ) 

 

 NFIRBERBEAM:  Enter the maximum number of fibers ( elements ) in any cross 

section (.TEM file) 

 

 NGEOTRUSS: Enter the number of different truss cross sections having the same 

geometry, materials and temperature history. 

NGEOSHELL: Enter the number of different shell sections having the same materials, 

thickness, reinforcing bars and temperature history. (i.e. the number of .TSH files ) 

NGSHELLTHICK: Number of integration points on the thickness of the element. 

NREBARS: Number of rebar layers in the shell elements. 

TIMESTEP: Enter the initial time step in seconds. 
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TIMSTEPMAX: this field is the maximum time step and is used only in dynamic 

calculation. 

UPTIME: Enter the time limit for the calculation in seconds. 

TIMEPRINT: Enter the time step for the output of results in seconds. 

After you changed any value of this dialog box you must push the Accept Data button 

or Close to leave the dialog box without any changes. 

Selecting the tab Output optional results shows the following dialog box: 

 

10. Defining material 

To define materials used in the structure select following menu: 

 Data-> Material 

 
 

In the General Tab. you have to select : 

Number of materials: Enter the number of materials used in the structure 
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For each of the materials used in the structure define materials Material1, Material2,  

 

From the pull down list you can select the following SAFIR materials: 

• STEELEC3 

• STEELEEC3DC 

• STEELEC2 

• PSTEELA16 

• SILCONC_EN 

• CALCONC_EN 

• INSULATION 

For steels enter values for E-Modulus, Poisson ratio and Yield strength. 

 For concrete materials the mask changes and you can enter  Poisson ratio, 

Compressive strength and Tension strength. 
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For material ELASTIC you can enter the E-Modulus and the Poisson ratio. 

Note: The materials you define here are the Global Material numbers you assign to the 

local materials in Property  Dialog box ( see above under point 5. ) 

11. Create the mesh 

For both Beam and Truss elements create Linear elements with 2 nodes. 

Note: The GiD –SAFIR interface will create for beam elements a 3rd node in the 

geometric middle of the 2 end nodes, when you start the calculation. 

For Shell elements use Quadrilateral elements with 4 nodes. 

Meshing->Element type->Quadrilateral 

Select all surfaces to assign this element type. 

To create the mesh select form the pull down menu: 

Meshing-> Generate 

GiD displays a dialog box where you can enter the element size, which is used in the 

case of non-structured mesh. GiD displays the number of nodes and elements it 

created and displays the mesh. 

If you want to control the number of elements on a system line, you can use structured 

meshing. Select from the pull down menu: 

Meshing->Structured->Lines 

Enter the number of elements to assign to lines. 

If you created surfaces which are surrounded by 4 curves you can create structured 

meshes with shell elements: 

Meshing->Structured->Surface 

Select a surface and assign the number of elements to the bounding curves.  
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To switch from mesh-view to geometry-view you can use the last Icon of the GiD-

Tool box on the left side of the display, or use the pull down menu: 

Geometry->View Geometry 

Meshing->Mesh view  or type Ctrl-m 

12. File the project 

To save the project select: 

Files->Save or type Ctrl-s 

13. Create the SAFIR input-file and run SAFIR 

From the pull down menu select: 

Calculate->Calculate window 

 

GiD displays the process-Window. Click the Start button to start the calculation.  

Click the Output view Button to display a window, where you can watch the progress 
of the calculation and also error messages of  SAFIR.  
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When SAFIR has finished the calculation GiD displays a dialog box, which lets you 
directly start the GiD-Postprocessor. 

If you prefer post processing with Diamond2004, remember that GiD has placed the 
SAFIR  out-file and the tem-file in the project-name.GiD directory.  

14. Post processing 

For post processing in GiD select from the pull down menu: 

Files->Postprocess  or click the Postprocessor Icon in the tool box. 

To view the deformation select from the pull down menu: 
 
Windows->View results 

Select Deformed and a time step and press Apply.  
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To view various results select from the pull down menu: 
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Select from the View list Scalar Line Diagram and from Results: 

• Displacements  

• Axial Force 

• Moment Mx 

• Moment My 

• Bending Forces 

• Membrane Forces 

• Stress in Thick (Sx, Sy, Sxy, Mises) 

• Stress in Rebar 

From the Step list select the time step and press Apply. 
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