GiD — SAFIR2007 3D Structural Analysis

GiD — SAFIR 3D-Structural Analysis User Interface
1. Create a GiD project of type Safir_Structural_3d

From the pull down menus select:

Data->Problem type->SAFIR2007-> Safir Structural 3d
Save the project by selecting from the pull down menu:
File->Save as...

GiD creates a directory with the entered project-name expanded by .gid and places a
number of help-files in this directory.

2. Create the system geometry
Units must be meters.

Construct the system geometry in 3D using GiD geometry commands . To change the

view to Isometric select from the pull down menu:
View->Rotate->Isometric

For beam and truss elements geometry is in most cases built by line entities.
Geometry->Create->Line

For shell elements GiD geometry must be built using NURBS surfaces.
Geometry->Create->NURBS surface

The complete set of geometry commands you will find under:

Geometry->Create
Geometry->Edit

Geometry->Delete
See also the menus:

Utilities->Copy and Utilities-Move
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les: Aiaw  Geometry Lblibes  (Dgta Mesh | Caleulate (Help

o G

N EAND S/

e
oz
=

&

biDvesens

Fick LEFTMOUSE to desplace wview (ESC to quit). :'
Fick LEFTMOLISE to desplace wiew (ESC to quif). :I
x -

Comtnand: | s

For details on how to create and manipulate geometry, look to the GiD reference

manual or online Help.

3. Define constraints for supports

From the pull down menu select: Data->Conditions->Constraints

The following dialog box is displayed:
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Paint-Constraints E E‘@_I
Local-dxe: -GLOBAL- —l|

v -Constraint:
v *-Canstraint:
v Z-Canstraint:
[ BOTH Constraint:
[ ROTY Corstraint:
[ ROTZ Corstraint;

fzsign | Enbties | Draw | Unassign

Cloze |

Select the appropriate constraints you need for a support, click the button Assign to

assign the constraints to a point (or node if you are in the mesh-view) of the structure.

To assign constraints to a line, click to the line icon on the constraints dialog box.

Consktraints

Line-Constraints g h? | @|
Local-dme:  -GLOBAL-  —1 |

v ¥-Constraint:

v -Canstraint:

v Z-Canstraint:

[~ ROTx Congtraint:

[ ROTY Constraint:

r IJIEITZ.EDnstrath_:-

|Essign Entitiez | Draw | Unassign

Cloze

Note: The GiD-SAFIR interface allows only constraints in the GLOBAL coordinate
system.
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4. Define Connections
To disconnect certain degrees of freedom on the end-node of beams or shells select

form the pull down menu select: Data-> Connections

a Sl

Disconnect degrees v K2 )
|dentifier: {Id1 v

I~ Disconnectx displacement
Disconnecty displacement

Disconnect z displacement

Disconnect y ratation

Disconnect 2 rotation

H B @|m = R

Disconnect x rotation ‘
Disconnect warping |

Aszsign Entities Diraw Unassign

Close

To disconnect some degrees in one point, mark the degrees to disconnect in the dialog
box and give an Identifier. Assign this Identifier to a point (Node).
Note: The GiD-SAFIR interface will create for this point a SAME-point.

Then, assign the same identifier using condition Disconnect Id to all the beam

elements that must form a rigid group disconnected from this node.

%4 Connections
g T
Disconnect Id - h? o)
Identifier: |l -
&sai'g_n Entities Dlraey Unassign I
Close
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Alternately you can assign this Identifier to a surface.

" Connections

Identifier: {Id1 v

‘ Assigh Entities Dira Unassign

Close

5. Define Loads

From the pull down menu select:

Data ->Loads

The following dialog box is displayed:

¥-Force (0.0
-Force |0.0
Z-Force (0.0
#-Moment | 0.0
r-Marment | 0.0
Z-tarment | 0.0

|gssign Entitiez | Draw | Unazsign

Cloze |

Enter Forces in Newton (N), Moments in Nm and assign it to points (nodes) of the

system geometry.

To assign distributed loads to system lines click to the line-icon of the dialog box:
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# preassune |EI.EI
Y preassune |EI.EI
£ preasiure |EI.EI

|gssigh Enttiez | Draw | Unazzign

Cloze |

Enter values in N/m to assign distributed loads to a system line. After meshing this

load is automatically transferred to all beam-elements of this system line.

To assign distributed loads to surfaces click to the surface-icon of the dialog box:

Global Shell Load | N3
& Pressure |EI.EI

Y Pregsure 0.0
£ Pressure 0.0

|gssign Entitiez | Draw | Unazsign

Cloze |

To view assigned loads click to the button Draw and select Colors.

6. Assign the temperature files to beam and truss elements

Form the pull down menu select:

Data ->Properties
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s
s Cossecion 3| N2/ @)

File-M ame |=afir.tem

Local-dwes -Atamatic- — |

Murnber of materials 1 — |
Matl Glabal Me[1
Mat2 Global Mr|2
Mat3 Global Me[=

Cloze i

Enter in the field File-Name the name of the Temperature file (TEM file ) for a cross-

section of beam.

Note: Unlike SAFIR which needs a 4™ node to describe the orientation of a cross

section on a beam, the GiD-SAFIR interface uses a local X’Y’Z’ axes system.

Global axes system
Beam

Local axes system

When you start the SAFIR calculation the GiD-SAFIR Interface creates the 4™ node in
the X’Y" plane.

Local-Axes: With this option you define the orientation of the cross section on a 3D-

Line. From the pull down list select Automatic, Automatic alt or Define.

Automatic: the local axis system is assigned automatically to the beam by GiD. The
final orientation can be checked with the Draw Local Axes option in the GiD

Properties window.

Note: The intuitive idea is that vertical beams have the Y' axe in the direction of

global X. All the other beams have the Y' axe horizontal and with the Z' axe pointing
up.
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Automatic alt: Similar to the previous one but an alternative proposal of local axes is
given. Typically, User should assign Automatic local axes and check them, after
assigning, with the Draw local axes option. If a different local axes system is desired,
normally rotated 90 degrees from the first one, then it is only necessary to assign again

the same condition to the entities with the Automatic alt option selected.

Define. You can create a different named local axes systems either with 3 points or the

X’ direction and an angle.

To display the local axes select:

Draw->All conditions->Only local axes

Enter the number of materials used in this cross-section. For each local material
number ( this is the material number in the .TEM file ) of this section enter the global
material number in the structure (this is the material number in the Problem data ->

General ->Material ).

Assign the data to a system-line (or to linear elements, if you are in the mesh-display)

To display assigned properties click the Draw button and select Color.

To assign Properties to TRUSS elements click to the arrow-icon and select TRUSS

Cross Section:

N
TRUSS Cross Section g @I
Temperature File-Mame |templl . bst
Area IEllili
Residual stess IElEli
global maternial number |0

Azzign | Entities| Qraw| Qnassign|

Cloze

Enter the Temperature File-Name of the temperature curve.
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Enter the Area of the cross section in square meters.

Enter the Global material number.

Assign the properties to a system line (or to linear elements in the mesh).

7. Assign temperature files to shell elements

Form the pull down menu select:

Data-> Properties

and click to the surface-icon on the Property dialog box:

NE
[SHELL Sectonpopery 2| K2/ )

Shell Temp File-M ame |test.tsh

Murnber of shell materials 1 —
Shell Mat1 Global Nr|1
Shell Mat2 Global Nr[2
Shell Mat3 Global Nr|3

Cloze i

Enter the name of the temperature file (. TSH file ) and the number of materials used

in the shell-section.

Assign to each local material in the shell section the global material number of the

material defined in the Problem ->Material.

Assign the property to a surface.

8. Assign mass to nodes, beams and shells

In the case of DYNAMIC calculation assign masses to nodes, beams and shells.
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Select from the pull down menu:

Data ->Mass

Mazz on Mode g N? | @]

tasz 1/0.0

hazz 2|00
kazz 3|00

|$ssign Entitiez | Draw | Unazsign

Cloze |

Mass 1 1s the mass [kg] linked to degree of freedom 1 of the node.
Mass 2 is the mass [kg] linked to degree of freedom 2 of the node.
Mass 3 is the mass [kg] linked to degree of freedom 3 of the node.

To assign self-weight mass to beam elements click to the line icon .

b azz on Beam g h? | @]
Digtributed-B eam-k azz |0.0
R atatianal-lnertia (0.0

&zsign | Entities | Draw | Unassign

Cloze

Distributed-Beam-Mass is the self-weight in kg/m of the beam.
Rotational-Inertia: (See §3.2 Series 23 SAFIR Ref.Manual)
Use Assign to assign this property to a system line.

To assign self-weight mass to shell elements click to the surface icon .
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Mass for Dynamic Calculation

3

Distributed-Shel-tass 0.0

&zzign | Entities | Draw | Unassign

LCloze |

Assign the Distributes-Shell-Mass in kg/m2 to as surface.

9. Assign general problem data

Form the pull down menu select:

Data->Problem Data
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T General

Calculation parameters | Output optional results |

Title 1 |Safir_Static_2[
Title 2 (Mesh_from_Gl

Fenumber BEMIUMGED —
Loads STATICPUREMNR  —
Convergence COMEBACE —

TIMESTEFRIMN 1.0

FRECISION |1.0e-3

MGEDOBEAM |1

MNG|2
MNFIBERBEAN [300

NGECTRUSS|0
NGEOSHELLlD
NGSHELLTHICK0
NREBARS0
TIMESTEP[12

LIFTIME (300

TIMEFRINT B0

Accept Close

This Dialog Box provides 2 tabs:

o Calculation Parameters

e  Qutput optional results
Parameters you can set here are described in more detail in the SAFIR Ref. Manual.
Title: Allows to enter 2 text lines, which are used as title in SAFIR

If one of the entered values is too small, SAFIR stops the calculation and writes the
values needed in the .OUT-file, respectively to the GiD Output window. Change the

values and restart the calculation.

Renumber: select RENUMGEO from the check box to reduce the bandwidth of the

stiffness matrix.
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Loads: Allows selecting the type of calculation. You can select from the pull down list

e STATIC PURE NR

e STATIC APPR_NR

e DYNAMIC PURE NR

e DYNAMIC APPR NR

e STATICCOLD PURE NR
e STATICCOLD APPR NR

Convergence: You can select COMEBACK and NOCOMEBACK
TimestepMin: Is the minimum time step in case of COMEBACK
Precision: 1s the small value, which must be reached for convergence.

NGEOBEAM: Enter the number of different beam cross sections having the same
geometry, materials and temperature history. ( or in other words, this is the number of

TEM files)

NG: Number of integration points for beam elements in longitudinal direction ( can be

2 or 3, for HASEMI calculation NG must be 2 )

NFIRBERBEAM: Enter the maximum number of fibers ( elements ) in any cross
section (.TEM file)

NGEOTRUSS: Enter the number of different truss cross sections having the same

geometry, materials and temperature history.

NGEOSHELL: Enter the number of different shell sections having the same materials,

thickness, reinforcing bars and temperature history. (i.e. the number of .TSH files )

NGSHELLTHICK: Number of integration points on the thickness of the element.

NREBARS: Number of rebar layers in the shell elements.

TIMESTEP: Enter the initial time step in seconds.
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TIMSTEPMAX: this field is the maximum time step and is used only in dynamic

calculation.

UPTIME': Enter the time limit for the calculation in seconds.

TIMEPRINT: Enter the time step for the output of results in seconds.

14

After you changed any value of this dialog box you must push the Accept Data button

or Close to leave the dialog box without any changes.

Selecting the tab Output optional results shows the following dialog box:

—

A1

1

Calculation parameters] Dutput optional results]

FPRIMNTDEFL Frint dizplacement
wariation

PRIMTTMPRT Print temperatures in the
fibers

PRIMTYELALC Print welocity and
acceleration

FRIMNTFHE Print out of balance farces
FRIMTREACT Frint reactions
FRINTMM Print internal forces of beams

Accept data | LCloze

10. Defining material

To define materials used in the structure select following menu:

Data-> Material

i Material

General | Materiall | M

1
i
Mumber of materials 2 « 3
4
g

I| hateriald |

Close

In the General Tab. you have to select :

Number of materials: Enter the number of materials used in the structure
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For each of the materials used in the structure define materials Materiall, Material2,

thh Material

General Materiall | baterial? |h-1aterial3 | |

Matetiall STEELECH —

katl E-hodulus|2.1e11
batl Poisson ratio|0.3
batl “ield strength 2. 4528

Ac:u::e pt Close

From the pull down list you can select the following SAFIR materials:

e STEELEC3
e STEELEEC3DC
e STEELEC2

e PSTEELAI6
e SILCONC_EN
e CALCONC _EN
e INSULATION

For steels enter values for E-Modulus, Poisson ratio and Yield strength.
For concrete materials the mask changes and you can enter Poisson ratio,

Compressive strength and Tension strength.

General Materiall | Materialz | Material3 |

Materiall SILCONCEMN —

bdat] Poisson ratio|0.3
hatl Compressive strength |3.0e7
batl Tension strength |0,

Accept Cloge
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11.

For material ELASTIC you can enter the E-Modulus and the Poisson ratio.

Note: The materials you define here are the Global Material numbers you assign to the

local materials in Property Dialog box ( see above under point 5. )

Create the mesh

For both Beam and Truss elements create Linear elements with 2 nodes.

Note: The GiD —SAFIR interface will create for beam elements a 3™ node in the

geometric middle of the 2 end nodes, when you start the calculation.
For Shell elements use Quadrilateral elements with 4 nodes.
Meshing->Element type->Quadrilateral

Select all surfaces to assign this element type.

To create the mesh select form the pull down menu:
Meshing-> Generate

GiD displays a dialog box where you can enter the element size, which is used in the
case of non-structured mesh. GiD displays the number of nodes and elements it

created and displays the mesh.

If you want to control the number of elements on a system line, you can use structured

meshing. Select from the pull down menu:
Meshing->Structured->Lines
Enter the number of elements to assign to lines.

If you created surfaces which are surrounded by 4 curves you can create structured

meshes with shell elements:

Meshing->Structured->Surface

Select a surface and assign the number of elements to the bounding curves.
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To switch from mesh-view to geometry-view you can use the last Icon of the GiD-
Tool box on the left side of the display, or use the pull down menu:
Geometry->View Geometry
Meshing->Mesh view or type Ctrl-m
12. File the project
To save the project select:
Files->Save or type Ctrl-s
13. Create the SAFIR input-file and run SAFIR
From the pull down menu select:

Calculate->Calculate window

Froject  Starttime  UID

frame3d Mon Oct 31 10:55:45 3256 calculating... =

=
4 o[

Cutput view | Fill |

Start | Start remu:ute| Remate... | Cloze |

GiD displays the process-Window. Click the Start button to start the calculation.

Click the Output view Button to display a window, where you can watch the progress
of the calculation and also error messages of SAFIR.
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5 putput info for ‘frame3d’ Thu Jun 14 14:29:31

SAFIR wersion 2007 iz running.

Pleaze type "FILENAME®™ of "FILENAME.IMN™
JAFIR is in subroutine DONIEE

SAFTIR has finished subroutine DONIEE

Lime = 12 .00000 sec.
Lime = 24.00000 sec.
Lime = j6.00000 sec.
Lime = 43 .00000 =sec.
Lime = 60.00000 sec.
ITER = 2, RELATIVE EIGEN VALUE = 0O.45352
Lime = ?2.00000 sec.
Lime = g4.00000 sec.
Lime = Q6.00000 =sec.

Kl

18

SAFIER iz allocating memory

When SAFIR has finished the calculation GiD displays a dialog box, which lets you
directly start the GiD-Postprocessor.

If you prefer post processing with Diamond2004, remember that GiD has placed the
SAFIR out-file and the tem-file in the project-name.GiD directory.

14. Post processing

For post processing in GiD select from the pull down menu:

Files->Postprocess or click the Postprocessor Icon in the tool box.

To view the deformation select from the pull down menu:

Windows->View results

Select Deformed and a time step and press Apply.
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s View Results & Deformation

Yiewresults  MainMesh | Reference mesh |
— Defarm main mesh
" Original & Deformed

Analysis: structural-30
Step:lEDD z [ Position wector
Eecult Displacements _J

factar: |35.14907 [ fixed deformation

Fesults will be drawn on this deformed model.

Apply Close

To view various results select from the pull down menu:

i View Results & Deformation

Wiew results | hain Mesh | Reference mesh |

RT= |‘v’eu:t|:|rLine Diagram = otep:

Analysis: |Strun:1ural—3|:l & |EEIEI Z
B Axial-Force
H Displacements
A boment by
@ #-homent by
@ Y-hdoment by
@ Z-hdoment hdy
# |Moment k|
H roment Mz

factar: |1.63567=-005

Apply Close
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Select from the View list Scalar Line Diagram and from Results:

e Displacements

e Axial Force

e Moment Mx

e Moment My

e Bending Forces

e Membrane Forces

e Stress in Thick (Sx, Sy, Sxy, Mises)

e Stress in Rebar

From the Step list select the time step and press Apply.
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